using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?(?:\d+(?:\.\d+)?).*?\K\d+(?:\.\d+)?";
string substitution = @"";
string input = @"fname <-'FS1_SCN0.83_axg3.csv";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}