re = /^.*?(?:\d+(?:\.\d+)?).*?\K\d+(?:\.\d+)?/mi
str = 'fname <-\'FS1_SCN0.83_axg3.csv'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result