use strict;
my $str = 'fname <-\'FS1_SCN0.83_axg3.csv';
my $regex = qr/^.*?(?:\d+(?:\.\d+)?).*?\K\d+(?:\.\d+)?/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";