import Foundation
let pattern = #"^.*?(?:\d+(?:\.\d+)?).*?\K\d+(?:\.\d+)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"fname <-'FS1_SCN0.83_axg3.csv"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)