# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^T]*)T/$1,/;t' <<< "2016-04-28T13:57:02\",\"3055551269\",\"Incoming\",\"Text\",\"0.0"