#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^([^T]*)T"
Local $sString = "2016-04-28T13:57:02","3055551269","Incoming","Text","0.0"
Local $sSubst = "$1,"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)