// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([^T]*)T").unwrap();
let string = "2016-04-28T13:57:02\",\"3055551269\",\"Incoming\",\"Text\",\"0.0";
let substitution = "$1,";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}