package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([^T]*)T`)
var str = []byte(`2016-04-28T13:57:02","3055551269","Incoming","Text","0.0`)
var substitution = []byte("$1,")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}