const regex = /^([^T]*)T/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^T]*)T', '')
const str = `2016-04-28T13:57:02","3055551269","Incoming","Text","0.0`;
const subst = `$1,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);