using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^T]*)T";
string substitution = @"$1,";
string input = @"2016-04-28T13:57:02"",""3055551269"",""Incoming"",""Text"",""0.0";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}