re = /^([^T]*)T/
str = '2016-04-28T13:57:02","3055551269","Incoming","Text","0.0'
subst = '$1,'
result = str.sub(re, subst)
# Print the result of the substitution
puts result