# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=^|>).*?(?=<|$)//gs;t' <<< "<html>
<body>
<h1>Hello World!</h1>
<p>
This is a page to <i>test</i>the regexp.<br/>
It seem to work.
</p>
</body>
</html>Text at the end is also removed.
"