import Foundation
let pattern = #"(?<=^|>).*?(?=<|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<html>
<body>
<h1>Hello World!</h1>
<p>
This is a page to <i>test</i>the regexp.<br/>
It seem to work.
</p>
</body>
</html>Text at the end is also removed.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)