#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(?<=^|>).*?(?=<|$)"
Local $sString = "<html>" & @CRLF & _
" <body>" & @CRLF & _
" <h1>Hello World!</h1>" & @CRLF & _
" <p>" & @CRLF & _
" This is a page to <i>test</i>the regexp.<br/>" & @CRLF & _
" It seem to work." & @CRLF & _
" </p>" & @CRLF & _
" </body>" & @CRLF & _
"</html>Text at the end is also removed." & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)