re = /(?<=^|>).*?(?=<|$)/
str = '<html>
<body>
<h1>Hello World!</h1>
<p>
This is a page to <i>test</i>the regexp.<br/>
It seem to work.
</p>
</body>
</html>Text at the end is also removed.
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result