import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|>).*?(?=<|$)";
final String string = "<html>\n"
+ " <body>\n"
+ " <h1>Hello World!</h1>\n"
+ " <p>\n"
+ " This is a page to <i>test</i>the regexp.<br/>\n"
+ " It seem to work.\n"
+ " </p>\n"
+ " </body>\n"
+ "</html>Text at the end is also removed.\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}