use strict;
my $str = '<html>
<body>
<h1>Hello World!</h1>
<p>
This is a page to <i>test</i>the regexp.<br/>
It seem to work.
</p>
</body>
</html>Text at the end is also removed.
';
my $regex = qr/(?<=^|>).*?(?=<|$)/sp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";