#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\s+\d+)?"
Local $sString = "THIS IS ALSO A STRING 123" & @CRLF & _
"THIS IS ALSO A STRING" & @CRLF & _
"THIS IS ALSO A STRING123"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)