// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\s+\d+)?").unwrap();
let string = "THIS IS ALSO A STRING 123
THIS IS ALSO A STRING
THIS IS ALSO A STRING123";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}