import Foundation
let pattern = #"(\s+\d+)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
THIS IS ALSO A STRING 123
THIS IS ALSO A STRING
THIS IS ALSO A STRING123
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)