re = /(\s+\d+)?/m
str = 'THIS IS ALSO A STRING 123
THIS IS ALSO A STRING
THIS IS ALSO A STRING123'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result