import re
regex = re.compile(r"(\s+\d+)?", flags=re.MULTILINE)
test_str = ("THIS IS ALSO A STRING 123\n"
"THIS IS ALSO A STRING\n"
"THIS IS ALSO A STRING123")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)