use strict;
my $str = 'THIS IS ALSO A STRING 123
THIS IS ALSO A STRING
THIS IS ALSO A STRING123';
my $regex = qr/(\s+\d+)?/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";