$re = '/(\s+\d+)?/m';
$str = 'THIS IS ALSO A STRING 123
THIS IS ALSO A STRING
THIS IS ALSO A STRING123';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;