# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!.*\.00$|0\.0$)[01]\.\d{1,2}$/\1!\2foo\3\4/gm;t' <<< "0.0
1.0
0.3
0.04
10.2
2,2
0.8
5.00"