re = /^(?!.*\.00$|0\.0$)[01]\.\d{1,2}$/m
str = '0.0
1.0
0.3
0.04
10.2
2,2
0.8
5.00'
subst = '\\1!\\2foo\\3\\4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result