import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\.00$|0\\.0$)[01]\\.\\d{1,2}$";
final String string = "0.0\n"
+ "1.0\n"
+ "0.3\n"
+ "0.04\n"
+ "10.2\n"
+ "2,2\n"
+ "0.8\n"
+ "5.00";
final String subst = "\\1!\\2foo\\3\\4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}