using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\.00$|0\.0$)[01]\.\d{1,2}$";
string substitution = @"\1!\2foo\3\4";
string input = @"0.0
1.0
0.3
0.04
10.2
2,2
0.8
5.00";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}