#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!.*\.00$|0\.0$)[01]\.\d{1,2}$"
Local $sString = "0.0" & @CRLF & _
"1.0" & @CRLF & _
"0.3" & @CRLF & _
"0.04" & @CRLF & _
"10.2" & @CRLF & _
"2,2" & @CRLF & _
"0.8" & @CRLF & _
"5.00"
Local $sSubst = "\1!\2foo\3\4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)