const regex = new RegExp('^(?!.*\\.00$|0\\.0$)[01]\\.\\d{1,2}$', 'gm')
const str = `0.0
1.0
0.3
0.04
10.2
2,2
0.8
5.00`;
const subst = `\1!\2foo\3\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);