use strict;
my $str = '0.0
1.0
0.3
0.04
10.2
2,2
0.8
5.00';
my $regex = qr~^(?!.*\.00$|0\.0$)[01]\.\d{1,2}$~mp;
my $subst = '\\1!\\2foo\\3\\4';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";