# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\"display_name\":\"([^\"]*)\",\"game\"//gm;t' <<< "
\"display_name\":\"test\",\"game\":\"test123\""