use strict;
my $str = '
"display_name":"test","game":"test123"';
my $regex = qr;\"display_name\":\"([^\"]*)\",\"game\";mp;
my $subst = '';
my $result = $str =~ s;$regex;$subst;rg;
print "The result of the substitution is' $result\n";