#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\"display_name\":\"([^\"]*)\",\"game\""
Local $sString = "" & @CRLF & _
"" & @CRLF & _
""display_name":"test","game":"test123""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)