$re = ';\"display_name\":\"([^\"]*)\",\"game\";m';
$str = '
"display_name":"test","game":"test123"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;