using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.+:\s+(\d+(?:\.\d+))\s+(\w+)\s+.*$";
string input = @"Spysannya z depozytu Suma: 10000.00 UAH Kod avtoryzatsii: 841738 Diysnyi do 15:42:52";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}