import re
regex = re.compile(r"^.+:\s+(\d+(?:\.\d+))\s+(\w+)\s+.*$")
test_str = "Spysannya z depozytu Suma: 10000.00 UAH Kod avtoryzatsii: 841738 Diysnyi do 15:42:52"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")