use strict;
my $str = 'Spysannya z depozytu Suma: 10000.00 UAH Kod avtoryzatsii: 841738 Diysnyi do 15:42:52';
my $regex = qr/^.+:\s+(\d+(?:\.\d+))\s+(\w+)\s+.*$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}