import Foundation
let pattern = #"^.+:\s+(\d+(?:\.\d+))\s+(\w+)\s+.*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Spysannya z depozytu Suma: 10000.00 UAH Kod avtoryzatsii: 841738 Diysnyi do 15:42:52"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}