re = /^.+:\s+(\d+(?:\.\d+))\s+(\w+)\s+.*$/
str = 'Spysannya z depozytu Suma: 10000.00 UAH Kod avtoryzatsii: 841738 Diysnyi do 15:42:52'
# Print the match result
str.match(re) do |match|
puts match.to_s
end