const regex = /^.+:\s+(\d+(?:\.\d+))\s+(\w+)\s+.*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.+:\\s+(\\d+(?:\\.\\d+))\\s+(\\w+)\\s+.*$', '')
const str = `Spysannya z depozytu Suma: 10000.00 UAH Kod avtoryzatsii: 841738 Diysnyi do 15:42:52`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}