#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*((?:\d+\.\d+)|(?:\d+))(?:\Z|\D)"
Local $sString = "251.51 Kb" & @CRLF & _
"232.113 Mb" & @CRLF & _
"35 ss" & @CRLF & _
" 325.10323 sd" & @CRLF & _
" 23 hhh" & @CRLF & _
"33ffg" & @CRLF & _
"22"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")