// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*((?:\d+\.\d+)|(?:\d+))(?:\Z|\D)").unwrap();
let string = "251.51 Kb
232.113 Mb
35 ss
325.10323 sd
23 hhh
33ffg
22";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}