import re
regex = re.compile(r"^\s*((?:\d+\.\d+)|(?:\d+))(?:\Z|\D)", flags=re.MULTILINE)
test_str = ("251.51 Kb\n"
"232.113 Mb\n"
"35 ss\n"
" 325.10323 sd\n"
" 23 hhh\n"
"33ffg\n"
"22")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")