import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*((?:\\d+\\.\\d+)|(?:\\d+))(?:\\Z|\\D)";
final String string = "251.51 Kb\n"
+ "232.113 Mb\n"
+ "35 ss\n"
+ " 325.10323 sd\n"
+ " 23 hhh\n"
+ "33ffg\n"
+ "22";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}