$re = '/^\s*((?:\d+\.\d+)|(?:\d+))(?:\Z|\D)/m';
$str = '251.51 Kb
232.113 Mb
35 ss
325.10323 sd
23 hhh
33ffg
22';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);