re = /^\s*((?:\d+\.\d+)|(?:\d+))(?:\Z|\D)/m
str = '251.51 Kb
232.113 Mb
35 ss
325.10323 sd
23 hhh
33ffg
22'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end