const regex = /^\s*((?:\d+\.\d+)|(?:\d+))(?:\Z|\D)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*((?:\\d+\\.\\d+)|(?:\\d+))(?:\\Z|\\D)', 'mg')
const str = `251.51 Kb
232.113 Mb
35 ss
325.10323 sd
23 hhh
33ffg
22`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}