# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s(http[^\s]+)//ig;t' <<< "href=\"http.some.com\"
http.
My link is at http:google.com"