#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)\s(http[^\s]+)"
Local $sString = "href="http.some.com"" & @CRLF & _
"http." & @CRLF & _
"My link is at http:google.com"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)